Supported Browsers

Informational Websites – (WordPress)

Public facing websites used for informational purposes.  These sites contains resources such as loan product offerings and services, contact information, and links to our online applications.

Examples of these sites include:

www.afrwholesale.com
www.elend.com
www.afrcorp.com

These sites are supported on the following browsers:

  • Desktop Browsers
    • Chrome (Latest version available here)
    • Edge (Win 10 Only)
    • IE 11
    • Firefox (Latest version available here)
    • Opera (Latest version available here)
    • Safari (Updates done through App Store)
  • Mobile Browsers
    • Android Browser 7.0 and up
    • Safari for Mobile
    • Chrome for Mobile (Latest version available here)
    • Firefox for Mobile (Latest Play Store version:here/ Latest App Store version: here)
  • Mobile OS
    • Android 7.0 and up
    • iOS 9.0 and up

The following browsers are currently NOT supported:

  • IE 10 and below

 

Mobile Apps

AFR has a number of Apps available in the Google Play Store and Apple App Store.

Examples of these apps are:

AFR Loan Center: (App Store / Play Store)

MyLoanCenter: (App Store / Play Store)

Currently supports the following mobile OS’s:

  • Mobile OS
    • Android 7.0 and up
    • iOS 9.0 and up

 

Web Applications

AFR has developed a suite of online applications that connect our clients / borrowers / internal users to our systems.

Examples of these Web Applications includes:

These Online Applications support the following browsers:

  • Desktop Web Browsers
    • Chrome (Latest version available here)
    • Edge (Win 10 Only)
    • IE 11
    • Firefox (Latest version available here)
    • Opera (Latest version available here)
    • Safari (Updates done through App Store)
  • Mobile Browsers
    • Android Browser 7.0 and up
    • Chrome for Mobile (Latest version available here)
    • Firefox for Mobile (Latest Play Store version: here/ Latest App Store version: here)
  • Mobile OS
    • Android 7.0 and up
    • iOS 9.0 and up

The following browsers are NOT supported:

  • IE 10 and below